Between 4:12 PM PT and 4:25 PM PT, some customers using BookIt for Forms, BookIt Links, and BookIt Handoff experienced a complete disruption.
Service has been fully restored and is operating normally.
We apologize for the disruption and are taking steps to ensure greater resiliency moving forward.
Resolved
Between 4:12 PM PT and 4:25 PM PT, some customers using BookIt for Forms, BookIt Links, and BookIt Handoff experienced a complete disruption.
Service has been fully restored and is operating normally.
We apologize for the disruption and are taking steps to ensure greater resiliency moving forward.
Identified
We have identified the cause of the issue affecting BookIt for Forms, BookIt Links, and BookIt Handoff.
We are implementing a fix and we expect to provide an update by 4:27 PM PT.
Thank you for your patience as we work to restore full service.