Long Loading Times on Scheduling Page
Resolved·Degraded performance

We have not seen any new reports of the long load times - this issue is now resolved

Fri, Apr 4, 2025, 05:38 PM
(1 hour ago)
·
Affected components
BookIt for Forms
BookIt Links
BookIt Handoff
Updates

Resolved

We have not seen any new reports of the long load times - this issue is now resolved

Fri, Apr 4, 2025, 05:38 PM

Monitoring

The frequency of loading issues has significantly decreased. We will continue to monitor the situation through the night.

Thu, Apr 3, 2025, 12:01 AM(1 day earlier)

Investigating

Prospects may be intermittently experiencing longer than average loading times when using the Scheduling page. The team is actively investigating the issue.

Users may also see an RSS enablement modal, despite having RSS already enabled. This is related to the ongoing issue that the team is investigating.

The workaround for the RSS modal is to perform a hard refresh of the page.

Wed, Apr 2, 2025, 09:33 PM(2 hours earlier)

Investigating

Prospects may be intermittently experiencing longer than average loading times when using the Scheduling page. The team is actively investigating the issue.

Wed, Apr 2, 2025, 08:55 PM(38 minutes earlier)