Between 1/01/2026 2:46 PM PT and 1/02/2026 9:43 AM PT, all customers using BookIt Chrome Extension experienced a complete disruption.
The Chrome extension experienced a temporary service disruption due to an infrastructure availability issue with our cloud provider, which impacted a backend service supporting the extension. Once the provider resolved the issue, our team completed recovery actions and fully restored service.
We apologize for the disruption and are taking steps to ensure greater resiliency moving forward.
Resolved
Between 1/01/2026 2:46 PM PT and 1/02/2026 9:43 AM PT, all customers using BookIt Chrome Extension experienced a complete disruption.
The Chrome extension experienced a temporary service disruption due to an infrastructure availability issue with our cloud provider, which impacted a backend service supporting the extension. Once the provider resolved the issue, our team completed recovery actions and fully restored service.
We apologize for the disruption and are taking steps to ensure greater resiliency moving forward.
Identified
We are aware of an issue causing elevated errors in BookIt Chrome Extension starting at 2:46 PM PT.
Our engineering team is actively investigating and working to implement a mitigation.
Thank you for your patience as we work to restore full service.